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Features

o Models business processes, flows, datastores and organizational units

o Dialogs capture resource information

o Different presentation styles and symbols

o Multimedia-media features for presentations including

1) Sound

2) Video

3) Graphics

4) Animation

5) Text and graphic annotations

o “Drill down” for capturing detail of each process; File → Open Down on
selected process creates new diagram for selected process

o Process = business function in repository; function/process may appear in both
FHD and PM (and Dataflow Diagrammer)

Process

Trigger or
external event

DatastoreInput
process

Org. Unit
(swim lane)

Outcome

Report Process

Graphic
Annotation
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“Common” Features

o File menu

o Control of colors, fonts, etc

o Customization options

o Edit → Properties

o Edit → Elements

o Including elements

o Managing diagrams

o Navigating to elements

o Consolidation

o Importing of other objects



For Evaluation Purposes Only
For training and licensing, see http://www.jeffreyjacobs.com

Using Designer/2000 for Analysis, Design and Prototyping Page 4
Copyright  1995, 1996 Jeffrey Jacobs & Associates

Creating New Diagrams

o  File → New

o Diagram existing functions, or create new  root function

o Control display of existing functions

o Search box only allows queries with %
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Customization

o Default fonts, colors and line widths for element types

o Default color of each part of swim lane

o X & Y specify size of all elements in diagrams (except flows); elements cannot
be sized individually

o Control display of element types; individual elements can be hidden via
View → Hide Selected

o Specify relative “unit” for animation

o Default display mode

o In symbolic mode, display label or time for Process/Store

o Save settings to configuration control file; multiple files may created (see
Advanced Configuration)
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Creating Organizations

o 

o To create child organization, click on parent organization

o To create new organization, click on “Unspecified” organization

o New organization is empty; any existing elements in Unspecified remain in
Unspecified; Unspecified cannot be deleted
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Hiding Child Organization

 

o  View → Organization Drill Up collapses child swim lanes of selected
parent; all elements are displayed in collapsed swim lane

o  View → Organization Drill Down expands child swim lanes of selected
parents

o +/- in parent unit can also be used to collapse/expand

Text annotation
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Resizing and Moving Organizations

o To resize swim lanes, select desired organization unit and use
<shift><up arrow> and <shift><down arrow>

o To move lanes, select desired organization and use <ctrl><up arrow> and
<ctrl><down arrow> to move lane; child lanes must be collapsed first
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Creating Processes

o 4 types of processes, with different symbols in enhanced mode

1) Process

2) Decision

3) Report

4) Data Entry

o  and click on desired location for process

o Enter information as appropriate
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Creating Flows

o 4 types of flows (no visual distinction)

1) Flow

2) Dataflow

3) Material Flow

4) Temporal Flow

o  , click on source process/store and click on destination store/process
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Creating Stores

o , click on desired location

o Three types of stores (no visual distinction)

1) “Store”

2) Datastore

3) Material Store
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Creating Triggers & Outcomes

o , click on desired process, fill in information for trigger

o , click on desired process, fill in information for outcome (same dialog as for
trigger)

o Triggers and outcomes can only be attached to processes and represent
beginning/end of process flow

o Process may have multiple triggers and outcomes
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Process Specific Information

o Edit → Properties, double click, select and <enter> or right mouse button menu

o Enter/update information
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Store Specific Information

o Edit → Properties, double click, select and <enter> or right mouse button menu

o Volume information

o Main tab disabled for datastore
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Flow Specific Information

o Edit → Properties, double click, select and <enter> or right mouse button menu

o Enable/disable animation;
useful for showing specific process paths

o Control displayed information; time + units computed from Main tab, which is
disabled for dataflow type

o Rule text is additional detail for flow condition, may be displayed on diagram

o Percentage is “how often is this flow followed vs other flows”

o Significant indicates that a flow is more important than other; a small circle is
displayed on the diagram at the source and/or destination of the flow

o AND/OR determines the logical grouping of flows for activating a process.
Process will wait for all ANDed flows to arrive before activation, but will
activate whenever an OR’ed flow arrives.
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“Main” Information

o Used for calculating process path/project management  information

o Total Time is used to determine animation time.  Other time fields are added to
Total time.

o Cost information is also cumulative

o Critical Path information is used for calculating and displaying critical path on
diagram (see Utilities → Calculate Critical Path)

o All other information is for reporting only
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Resource Information

o Capture information about key resources and quality (no affect on diagram)



For Evaluation Purposes Only
For training and licensing, see http://www.jeffreyjacobs.com

Using Designer/2000 for Analysis, Design and Prototyping Page 18
Copyright  1995, 1996 Jeffrey Jacobs & Associates

Text

o Various text types for reporting

o “Use in Application Development” information only (remember, all processes
are “functions” in the repository)
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View Options

o Specify information to hide/display on diagram

o Hide and redisplay selected elements

o Collapse/expand multi-level organization units

o Hide/display text and icon annotations
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Symbol Mode

o All processes displayed as squares

o Total time or label for each process displayed, determined in Options →
Customize dialog



For Evaluation Purposes Only
For training and licensing, see http://www.jeffreyjacobs.com

Using Designer/2000 for Analysis, Design and Prototyping Page 21
Copyright  1995, 1996 Jeffrey Jacobs & Associates

Enhanced Symbol Mode

o Display different process symbols for appropriate types
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CASE is for people who believe there is more to life than debugging the code they write!
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Multimedia Features
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Iconic Mode

o Display icons

o Default icons for each element type are specified in the
File → Configuration →Advanced dialog

o Specific icons for individual elements specified in Multimedia tab (Edit →
Properties)

o “Smart” icon files may be created, associating specific icons with key words in
element names (File → Configuration →Advanced dialog)

o Icons may be turned off for flows



For Evaluation Purposes Only
For training and licensing, see http://www.jeffreyjacobs.com

Using Designer/2000 for Analysis, Design and Prototyping Page 25
Copyright  1995, 1996 Jeffrey Jacobs & Associates

Specifying Multimedia

o Specify icon and sound to be used in animation; icon is also used in iconic
display mode

o  plays sound for selected element in diagram

o Associate video clip with element;  plays clip

o Associate image with element;  displays image

o Associate an executable program with element;  to execute

o Associate .BMP or .DIB files with element as annotation for display in diagram

o Annotations may be graphic only, text only, or both

o Define text annotation for element
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Selecting Multimedia

o  in Multimedia tab brings up preview/edit dialog

o Default Path is specified in Options →Customize → Basic dialog (described
below)

o Files may be previewed, edited or created by programs specified in
Edit → Configuration → Basic dialog (described below)

o  displays .BMP files full size

o  invokes editor to modify or create a new file
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Configuring Multimedia

o Options → Customize → Basic

o User commands are command string that can be run from
Tools → User Commands (useful for running spreadsheets, word processors,
etc)

o Specify directory containing multimedia file types

o Specify programs for editing multimedia types

o “Preview” specifies programs for displaying in diagrammer (or previewing)
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Video

o  using Preview Video program specified in configuration dialog

o May not play automatically, depending on program
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Images

o  displays picture using Preview Image program specified in configuration
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User Commands

o Run commonly used programs
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Animation
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Animation

o Dynamic, parallel animation of icons based on Total Time for each element

o Process and stores “animate” by cycling through 3 .bmp files named
<name>1.bmp, <name>2.bmp and <name>3.bmp for each animation step

o Flows “move” from source to destination (except dataflows); <name>1.bmp is
shown at start of flow, <name>2.bmp is show in middle of flow, and
<name>3.bmp is shown at the end of flow for each animation step

o Sounds are played for elements with associated sounds;
Utilities → Animation → Sound or <alt>-D disables/enables sound
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Animation Options

o Utilities → Animation → Options

o Time Step determines the unit of time for animating each element; each step will
produce 1/2 second of animation

o Work time is used to calculate animation time for elements who Total Time is in
different units, e.g. if a process takes 1 day, how many hours are in the day for
animation purposes?

o Automatic Animation Tracking determines if window is automatically scrolled to
follow currently animated elements; set this on!
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Controlling Animation

o Animation may be started, suspended and resumed

o Skip to Next Event moves to next animation event; useful when animation is
taking too long

o Sound may be enabled/disabled

o More than one process path may be animated

1) Select desired starting process(es)

2) Start animation from menu or 
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ANDed Flow Blocking

o If a process has multiple flows entering it, and those flows are ANDed together,
the process is blocked from animating and continuing until all flows complete

o The blocked process will display its name and flash green and red

o When all ANDed flows complete, normal animation takes place

o If an ORed flow completes, the process will animate normally, then return to
waiting for the ANDed flows
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Almost useless page
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Advanced Features
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Advanced Configuration Overview

o Options → Customize → Advanced

o Specify default icons for each element type

o “Specify Icon Data File”.  This is a text file that associates key words with icon
files.  Element created with the key word in the name will use the associated icon
instead of the default icon.

o “Use Multimedia on Database” stores multimedia associated with individual
elements in the repository, allowing the same multimedia information to easily be
used in multiple diagrams

o “Fill Label on Create” results in automatic creation of short names for element
created in the diagram.

o Multiple graphical preference files may be maintained.  If a file is specified here,
the SAVE button in the Edit → Preference dialog will allow updating of existing
files or creation of new files.  These files are kept in the \WINDOWS directory.

o See HELP for additional information.



For Evaluation Purposes Only
For training and licensing, see http://www.jeffreyjacobs.com

Using Designer/2000 for Analysis, Design and Prototyping Page 39
Copyright  1995, 1996 Jeffrey Jacobs & Associates

Reports

o Tools → Reports

o Various reports available

o Note that this screenshot is from R1.3.  The BPR Model group does not exist in
R2.1.1.  However, most of the reports do exist.  Create your own BPR group!
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Exporting

o Utilities → Export Data

o Export data in various formats

1) Comma delimited for spreadsheet for elements

2) Comma delimited for spreadsheet for organization units

3) CASE 5.1

4) “Proprietary” format (process modeller ASCII file format)

o If Proprietary format specified, various options for controlling exported data (see
HELP for additional information)


